
“IMAGE DOWNLOAD & VISUALIZATION" 

Learning Unit 



“Image Download & Visualization" 

In this learning unit you will have the first hands on experience using 

the SPRING software package. 

 

You will learn how you can download a remote sensing images from 

the web catalogue and how visualize it in the SPRING project. 



IMAGE DOWNLOAD  

Image Catalogues of Remote Sensing – Types and Download 

At the late 1990s, with the advance and consolidation of the Internet, image 

repositories became more accessible and allowed access to online data. These 

repositories or image catalogues are web applications that publish metadata and 

provide research and restoration of distributed repositories (Chae et al., 2004). In 

general, they have a good web interface with repositories information, browsing and 

search engines.  

Like all technology beginnings, the catalogues were created by their institutions 

individually, without any interface, software and hardware pattern. Such different and 

unconnected environments waste users’ time while learning the usage of interfaces 

and, subsequently, integrating data from different catalogues. Therefore, 

understanding the organization and functioning structures of each catalogue, as well 

as the images available, is important. 

In general, there are three main interfaces in the Catalogues: search, metadata 

publishing and data access. These three access and search pillars are important in 

the usage of these tools. 
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IMAGE DOWNLOAD  

The USGS Catalogue 

The U.S. Geological Survey – USGS, the United States government agency that collects, 

monitors, analyze and provide scientific information on natural resources, releases satellite 

images from various sensors and derivative data, such as orthophotos and digital elevation 

models (USGS Technical Announcement). The catalogue has two interfaces: USGS Earth 

Explorer (http://earthexplorer.usgs.gov/), a query interface that provides both spatial and temporal 

search filters 
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and the USGS Global Visualization Viewer – GLOVIS (http://glovis.usgs.gov/), that, besides 

query tools to catalog, is the interface to Download Data 
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The Global Land Cover Facilities Catalogue 

The Global Land Cover Facilities - GLCF is a Center that develops and distributes remotely 

sensed satellite data and products that explain land cover from the local to global scale. The 

Earth Science Data Interface – ESDI (http://glcfapp.glcf.umd.edu:8080/esdi/index.jsp) is the 

GLCF's web application for searching, browsing, and downloading data from our online holdings. 

The interface allows browsing for sensor images (Path/Row), bounding box (Lat/Long) or using 

the interactive map 
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The SPOT Catalogue 

ASTRIUM GeoInformation Services provides exclusive access to SPOT images 

through its catalogue, which has an available interface at 

http://catalog.spotimage.com/PageSearch.aspx. Besides providing polygon drawing 

tools, which is interesting in the interactive map, the interface allows coordinates 

bounding box browsing as well as shapefiles 
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The European Space Agency provides at eoPortal an online support with links to 

several image catalogues and thematic products. The Service Support Environment 

can be accessed at 

http://services.eoportal.org/portal/service/ListService.do?serviceCategoryId=34801780

, and addresses to many catalogues through browsing interface, such as MODIS 

The Service Support Environment 
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The INPE Catalogue 

The National Institute for Space Research – INPE, in Brazil, releases CBERS images 

and scenes from the entire Landsat family in South America (and others), acquired in 

the receiving antenna in Cuiabá. The access portal (http://www.dgi.inpe.br/CDSR/) 

releases, under previous register of its users, the image catalogue in a search 

interface with further download via FTP 
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Main search functions in satellite image catalogues 

Search functions are tools performed in sequential steps that allow browsing 

using geographic criteria, as well as non-geographic attributes. The main searching 

tools are associated with a geographic position. Among the most important search 

engines it is possible to name: geographic coordinate insertion, area editing using 

maps that provide function such as polygon drawing, zoom and navigation or even 

the function of downloading a shapefile or kml file in the area of interest. 

It is important to observe that not all images are available to download in these 

catalogues. Some image collections are available only for browsing and, in some 

cases, the user can ask for the scenes to download in a further step. In INPE, ESDI 

and SPOT catalogues it is possible to obtain all data under online registration. 

However, in Earth Explorer and GLOVIS some collections are available for browsing 

only. In the eoPortal all catalogues scenes are available for browsing only. 
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EJERCICIO PRÁCTICO (Guiado) 

BUSCANDO Y BAJANDO IMÁGENES LANDSAT DEL CATÁLOGO USGS 

El objetivo de este ejercicio es seleccionar imágenes del sensor OLI/Landsat8 que 

cubran la Cuenca del rio Maipo, directamente del catálogo USGS 

(http://earthexplorer.usgs.gov/) 

PASO 1. Crie una 

carpeta en su 

computador, donde 

serán guardadas las 

imágenes  

PASO 2. Es necesario 

hacer un registro de 

login 
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PASO 3. En los criterios de búsqueda, seleccione Path/Row 01/081. Pulse Show para 

mostrar la localización de la escena  

EJERCICIO PRÁCTICO (Guiado) 

BUSCANDO Y BAJANDO IMÁGENES LANDSAT DEL CATÁLOGO USGS 



EJERCICIO PRÁCTICO (Guiado) 

BUSCANDO Y BAJANDO IMÁGENES LANDSAT DEL CATÁLOGO USGS 

PASO 4. En el campo Data Range, seleccione el intervalo de fechas. Pulse Data Sets para 

seleccionar el sensor 



STEP 5. Seleccione L8 OLI/TIRS en Landsat Archieve. Es posible refinar la búsqueda con 

criterios adicionales (Addditional Criteria) como el porciento de cobertura de nubes en la 

escena. Al final, pulse Results 
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EJERCICIO PRÁCTICO (Guiado) 

BUSCANDO Y BAJANDO IMÁGENES LANDSAT DEL CATÁLOGO USGS 

STEP 6. Una lista de escenas que atienden los criterios de búsqueda irá aparecer. Visualize as 

cenas utilizando el ícone Show Browse Overlay. Una vez escogida la imagen que se desa 

bajar, pulse el ícone Download Option 



EJERCICIO PRÁCTICO (Guiado) 

BUSCANDO Y BAJANDO IMÁGENES LANDSAT DEL CATÁLOGO USGS 

STEP 7. Utilize la ventana de Download Options para bajar las imágenes. Repita la operación 

para todas las cenas que cubren la cuenca del rio Maipo, Path/Rows: 01/082; 233/081 y 

233/082 



THE SPRING SOFTWARE 

SPRING (System of Georreferenced Information Processing), which is considered a 

geographical data base of second generation, was built by the National Institute for Space 

Research/ Division of Image Processing with the participation of EMBRAPA/CNPTIA, IBM 

Brazil,  TECGRAF-PUC Rio and PETROBRÁS/CENPES. Furthermore, it counted with the 

financial support of CNPq through RHAE and PROTEM/CC (GEOTEC project). The system 

that operates UNIX and Windows presents as its main functions spatial analysis, image 

processing, digital terrain model and querying of spatial database.  

 
Download 

The current platform of the Division of Image Processing of INPE allow free download of 

SPRING in Portuguese, English, Spanish and French versions. Moreover, SPRING fits in 

Linux and Windows 95/98/NT/ME/2000/XP/Vista/7 operating systems. 

The software’s license is available in INPE platform. If you are interested in consulting it, check 

SPRING license. 

To access the entire SPRING website, it is necessary to register first. Later, upon login, users 

are identified by their e-mail and password. To download SPRING go to 

http://www.dpi.inpe.br/spring/ 
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THE SPRING SOFTWARE 

Install 

 

After downloading, open the executable file (_.exe) to install. It is important to observe that the 

main SPRING module setup comprises two more programs – SCARTA and IMPIMA, which are 

also available for free download. 

Before working with SPRING, it is important 

to understand the system conceptual model, 

which describes how the geographic reality 

will be represented. By installing SPRING 

you will have an online help system in your 

computer. In the SPRING online help initial 

page select Concepts and, afterwards, 

Reference Information, then read more 

about SPRING Conceptual Model. 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SPRING 

The aim of this guided exercise is simply to present the SPRING system. You will know 

how organize the information in a hierarchy of spatial Database. This organization is 

subdivided into four data models: Database, Project, Category and Information Layer 

An SPRING Database corresponds physically to a directory where the Data Model, with its 

Classes and Categories definitions, as well as the Database projects will be stored, all of them 

are presented in the taskbar of software. 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

Create Database 

 

In order to enter data in the SPRING System, it is first required to create a Database and 

define its Data Model. In order to perform any task, a Database has to be active and the data 

categories that will be handled in the Database have to be declared. 

 

STEP 1. Create a Database: Click in File>Database, in the main menu or in the 

corresponding icon in the toolbar. 

 

STEP 2. Select directory and Database name: Click in Directory...to select a directory where 

the Database will be created. Type the name for the Database that will be created (example: 

“Maipo”). You can use up to 32 characters without spaces.  

 

STEP 3. Select a Database Manager among Dbase, Access, Oracle, MySQL, PostgreSQL 

or SQLite. 

 

STEP 4. Confirm: Click in Create to create the Database. If a backup is needed, all 

information and data of this database will be stored in the selected directory. 

 

STEP 5. Activate Database: Click in Apply to activate the Database. Notice that the name of 

the active Database is presented in SPRING title bar between brackets. 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

Create Project 

 

Once the Database is created, it will 

be necessary to define a Project with 

its geographical limit of the area under 

study (Bounding Box) and 

the Cartographic Projection that is 

more adequate to the geographic area 

that will be manipulated in the work 

area. Once these parameters are 

defined, then it is possible to enter or 

handle data in the SPRING System. 

The projects will be stored in sub 

directories together with its data files: 

points, lines, orbital and aerial images, 

thematic images, texts, grids and 

objects. 

 

STEP 1.Create a project: Click on 

File>Project...in the main menu or in 

the corresponding icon in the toolbar. 

 

STEP 2. Type a name for the project 

(example: “Maipo”). 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

 

STEP 3. Define the cartographic 

parameters: Click on Projection... to 

inform the cartographic parameters to be 

used in the project. Select the LATLONG 

System (Geographical Coordinates 

System) and WGS84 model (World 

Geodetic System defined in 1984). Click in 

Apply to define the projection. Note that 

the longitude of origin will be filled 

automatically. 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

STEP 4. Define the Bounding Box 

in Geographic or Planes 

coordinates (in meters). The two 

points should be diagonally opposite 

to each other, such that the first (1) is 

the lower left corner while the second 

(2) is the upper right corner. For the 

Maipo’s basin use the Geographic 

coordinates: 

Long1: - 70.000 Long2: - 69.900 

Lat1: -34.000 Lat2: -33.300 

Click on Create to insert a project in 

the database. Note that the project 

name will appear on the Projects box 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

STEP 5. Load the project: Many projects can be stored in the SPRING Database. Therefore, 

select the "Macae" project to continue with the exercise. Click on Load to activate this project. 

 

Note that in the SPRING title bar the name of the loaded Database and project is presented 

within brackets [<Maipo>][Maipo]. 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 

Create Categories 

 

To add data into SPRING it is required to define the different types of data that will be handled. 

Every map has to belong to a Category, that is, it has to belong to one of the following types: 

Image, Digital Terrain Model (DTM), Thematic, Cadastral or Network (you can see the 

conceptual definition of each type in the SPRING online-help). 

 

As we will use remote sensing image with matrix format, the “Image” category is more 

appropriate to this kind of data. 

 

STEP 1. Create a category: Click on File>Data Model... in the main menu or in the 

corresponding icon in the toolbar. The “Data Model” dialog box will appear with the different 

categories used in the SPRING System. 

 

STEP 2. Choose Image as type of Data Model. Assign a name for the category, for example: 

“Landsat”, to help identify the origin of the images you are inserting on the Database. 

 

STEP 3. Click on Create and then on Execute. 

 

This procedure can be repeated to create others categories 



PRACTICAL EXERCISE (Guided Exercise) 

STARTING SRING 



PRACTICAL EXERCISE (Guided Exercise) 

LOAD AND VISUALIZE IMAGE 

In the SPRING System, data can be imported in different formats (see SPRING on-

line help for more details) provided that they are appropriate according to the 

previous definition of the Category. Most of the satellite images currently distributed 

by private companies or research organizations are geometrically corrected. 

Although the images in the GeoTIFF format could not be completely georeferenced, 

it should be imported to the SPRING project. In the current practical exercise, you 

will use the Landsat image previously downloaded from INPE Catalog and import it 

to “macaé” project. 



PRACTICAL EXERCISE (Guided Exercise) 

LOAD AN VISUALIZE IMAGES 

Import image in GEOTIFF format 

 

STEP 1. Click on File>Import>Import Vectorial and Matricial Data... in the main menu to open 

the Import dialog box. 



STEP 2. Select file: Click on File... and 

select, in your directory, one of the files 

in GEOTIFF format corresponding to 

each band of the Landsat image 

previously downloaded. Click on Apply. 

The Data tab will show image attributes 

as Projection and Pixel Size (30 

meters for Landsat image). Use the 

Bounding Box defined for “Maipo” 

project. 

 

STEP 3. In the Output tab, choose the 

category previously created for image 

data (“Landsat”) and type a name for 

the Information Layer (IL). It is 

advisable to specify the spectral band 

of the image in the filename, to 

facilitate identification (example: 

Band_1). Click on Apply to import the 

image. To import the other bands, the 

procedure is the same and should be 

done in sequence. The imported 

images will be displayed on the control 

panel. 

PRACTICAL EXERCISE (Guided Exercise) 

LOAD AN VISUALIZE IMAGES 



PRACTICAL EXERCISE (Guided Exercise) 

LOAD AN VISUALIZE IMAGES 

Visualization of the images inserted in the Project 

 

This step consists in viewing the images in grayscale separately and through normal composition 

and false color. 

STEP 1. Add screens: Each 

added image will be visualized in 

a SPRING screen, therefore, add 

the number of screens 

corresponding to the quantity of 

images, aside from the "Main" 

and "Assistant" screens. This 

procedure is done with the  tool 

(“Add Screen”), located on the 

bottom of the visualization area. 

In case you have added 5 bands, 

you will need 5 screens. 

 

STEP 2. Click on Screen 2, on 

the bottom, and select the first 

image on the Control Panel. 

Below the Control Panel, activate 

the M option that represents the 

gray levels. 

Repeat the process for the other added images, 

indicating to the next screen (Screen 3, 4, 5...) the next 

image on the list, activating the box with the M option. 



STEP 3. False color composition: To elaborate this composition, use the bands 4 (red), 5 (near 

infrared) and 6 (swir). Click on the Main screen to activate it, then select, through the Control 

Panel, the corresponding image to the band 4 and activate the B (Blue) box; click on the band 5 

image and activate the G (Green) box and, lastly, click on the band 6 image and activate the R 

(Red) box. 

PRACTICAL EXERCISE (Guided Exercise) 

LOAD AN VISUALIZE IMAGES 



Visualization tools 

 

In SPRING's main toolbar, several navigation and zoom tools are available, to aid in the image 

visualization. 

Zoom cursor 

Cross cursor 

Roming cursor 

Info cursor 

Digitizer cursor 

Draw 

Zoom in 
Zoom out 

Zoom IL 

Previus 

Reset 
Attach 

Zoom Cursor: defines the area you 

want to enlarge. 

 

Roaming Cursor: moves the image 

inside the visualization screen. 

 

Info Cursor: obtains information 

about the image inside the 

visualization screen. 

Zoom In and Zoom Out: the Zoom In  tool enlarges 

2 times the central area of the image and the Zoom 

Out  tool reduces 2 times the center of the screen. 

To come back to the normal size of the image, click 

on the Zoom IL icon. 

 

Zoom: allows you to enlarge the visualization of an 

area 2, 4 and 8 times in a window that floats on the 

main screen. 

PRACTICAL EXERCISE (Guided Exercise) 

LOAD AN VISUALIZE IMAGES 
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REMOTE SENSING OF THE ENVIRONMENT: AN EARTH RESOURCE PERSPECTIVE. 2nd 

Edition by JOHN JENSEN, published by Pearson Education, Inc., publishing as Prentice Hall, 

2007, 316p. 
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FURTHER LITERATURE 

Internet Resources 

 

The WWW Virtual Library: Remote Sensing http://virtual.vtt.fi/space/rsvlib Extensive links to 

satellite data sources, journals and on-line publications, societies, and companies and other 

organizations engaged in remote sensing. 

 

Remote Sensing Tutorial created by the Goddard Space Flight Center http://rst.gsfc.nasa.gov  

or  http://www.fas.org/irp/imint/docs/rst/ An application-oriented on-line tutorial covering all 

aspects of remote sensing, including thermal images and radar, with many sample images. 

 

Remote Sensing Tutorials created by the Canada Centre for Remote Sensing 

http://www.nrcan.gc.ca/earth-sciences/geography-boundary/remote 

sensing/fundamentals/1430 On-line tuturials in remote sensing fundamentals, radar and 

stereoscopy, and digital image analysis. 
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